Bug #82424

T3editor: Get default mode if none is defined

Added by Andreas Fernandez over 4 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Category:
t3editor
Target version:
Start date:
2017-09-09
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
Yes
Sprint Focus:
On Location Sprint

Description

If a field is rendered by t3editor and no mode is defined for that field, the ModeRegistry will encounter a PHP warning.

How to test

Requirement: EXT:styleguide installed
Open a "inline expand" element and expand the contained inline field. You'll get a 500 response.


Related issues

Related to TYPO3 Core - Feature #81901: Refactor t3editorClosedAndreas Fernandez2017-07-17

Actions
#1

Updated by Andreas Fernandez over 4 years ago

#2

Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54085

#3

Updated by Andreas Fernandez over 4 years ago

  • Description updated (diff)
#4

Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54085

#5

Updated by Andreas Fernandez over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Benni Mack over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF