Bug #82618

Multistep with httpMethod get. cHash empty

Added by Juan Manuel Vergés Solanas over 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2017-09-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When you create a multistep form, if you set httpMethod = get in the Yaml, then when you click in next step then you get the error:

Page Not Found
Reason: Request parameters could not be validated (&cHash empty)

#1

Updated by Ralf Zimmermann over 4 years ago

This is an advanced setting and don't work out of the box.
The current EXT:form implementation use only the http method "post".
If you use EXT:form within you own extension with your own implementations you can switch the httpMethod to something else if you want.

#2

Updated by Bjoern Jacob almost 4 years ago

  • Status changed from New to Closed

I am closing this since it is not an issue of the form framework. I hope this is alright for you. If not, please re-open this ticket or create a new one.

Also available in: Atom PDF