Project

General

Profile

Actions

Bug #82735

closed

Problem with Feature: #73409 - Auto-render Assets sections

Added by SICOR KDL GmbH almost 7 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Fluid
Target version:
-
Start date:
2017-10-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.1
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hello there,

we have a problem regarding above mentioned feature. We use the extension news and have a category list which links to a RSS feed page. It always works once, right after the cache is cleared, but when hitting browser back and selecting another category we get the error:

PHP Warning: in_array() expects parameter 2 to be array, null given in /var/www/typo3_system/typo3_sources/typo3_src-8.7.7/vendor/typo3fluid/fluid/src/Core/ViewHelper/ViewHelperResolver.php line 92

In the TRACE we see:

renderSection("HeaderAssets", array, boolean)
...
addNamespace("content", NULL)

Since adding header or footer sections is somewhat meaningless when rendering plain RSS-Feed-XML anyway, I wonder if we can just disable the Asset Auto render on that page? Any Typoscript for that?

Greetings,
Manuel


Related issues 1 (0 open1 closed)

Precedes TYPO3 Core - Bug #82957: Render Bug in typo3temp/var/Cache/Code/fluid_templateClosed2017-10-122017-10-12

Actions
Actions #1

Updated by Claus Due almost 7 years ago

I have a suspicion I'd like to confirm, but before I go digging too deep:

1. Could you please either paste or link the template that gets rendered when this happens?
2. Can you confirm that this also happens with the same category RSS feed if you flush the page cache only and reload? This is to check that the problem is triggered from the compiled template and is not dependent on input values.

Those two bits of information should help me fix this one. I suspect it needs a fix in Fluid but I need to know the actual cause to know what the proper fix should be.

Actions #2

Updated by SICOR KDL GmbH almost 7 years ago

Hello,

thanks for looking into this. We didn't modify the template thus far, it's plain ext/news/Resources/Private/Templates/News/List.xml
Should be online here: https://github.com/georgringer/news/blob/master/Resources/Private/Templates/News/List.xml

The first choosen category works constantly, even when browser back is hit. To choose another category, hitting the red "All Cache" button is required, the green "Frontend cache" button has no effect in the scenario.

Actions #3

Updated by SICOR KDL GmbH over 6 years ago

  • Precedes Bug #82957: Render Bug in typo3temp/var/Cache/Code/fluid_template added
Actions #4

Updated by Simon Ouellet over 6 years ago

I have the same problem too.

After a search, I've found that the Fluid team might have fixed the bug.
https://github.com/TYPO3/Fluid/pull/283

Actions #5

Updated by Claus Due over 6 years ago

  • Status changed from New to Resolved

Fixed a while ago in https://github.com/TYPO3/Fluid/commit/9772be318df13be8cc2e5b6e46b9a510220739b9 - is included in all most recent releases of TYPO3 v8 and up.

Actions #6

Updated by SICOR KDL GmbH over 6 years ago

Tested with 8.7.10 - works now!

Actions #7

Updated by Benni Mack almost 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF