Bug #82834

Update Symfony packages to latest versions

Added by Helmut Hummel 7 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-10-20
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Related issues

Related to TYPO3 Core - Task #83289: Set composer config platform.php Resolved 2017-12-11

Associated revisions

Revision 060c94e7 (diff)
Added by Helmut Hummel 7 months ago

[TASK] Update Symfony packages to latest releases

Update all Symfony packages for the distribution
release to latest versions.

Composer users get these versions anyway, so
no issues are expected here.

Composer command: composer update symfony/*

Releases: 8.7
Resolves: #82834
Change-Id: Ib3a528333abcc72124d2540b9edcbb2431893651
Reviewed-on: https://review.typo3.org/54459
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>

Revision 49b63d93 (diff)
Added by Christian Kuhn 5 months ago

[TASK] Set composer config platform.php 7.0.0

Similar to what has been done in v7 already, v8 now
sets config.platform.php in composer.json.

See https://getcomposer.org/doc/06-config.md#platform
for more details.

Mind this setting (as all other 'config' section settings)
is only valid for the root composer.json file,
it has no meaning if core is used as dependency in a project
with its own composer.json file. For core however, this setting
is relevant since composer.json is also used as root file
during packaging of standalone core packages.

The setting now effectively prevents core from installing
dependencies that require higher PHP versions, even if the
locally installed PHP version is higher.

The value is set to 7.0.0: Symfony raised PHP requirements
from 7.0.0 to 7.0.8 between 3.3.6 and 3.3.7 versions, setting
7.0.0 as platform.php thus forces downgrade from 3.3.10 to 3.3.6
of symfony dependencies. Wether we raise to 7.0.8 ourselfs for
v8 may be decided with another patch if really needed. This
version downgrade from 3.3.10 to 3.3.6 should be ok since
the upgrade happened with #82834 which has not yet been released
in a stable v8 patch level release.

Composer commands used:

composer config platform.php 7.0.0
composer up symfony/*
composer update --lock

Change-Id: I367309d6c57a5582980101c95c170d64273ed89e
Resolves: #83289
Related: #83223
Related: #82834
Releases: 8.7
Reviewed-on: https://review.typo3.org/55034
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Gerrit Code Review 7 months ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54459

#2 Updated by Gerrit Code Review 7 months ago

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54459

#3 Updated by Gerrit Code Review 7 months ago

Patch set 3 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54459

#4 Updated by Helmut Hummel 7 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Christian Kuhn 5 months ago

  • Related to Task #83289: Set composer config platform.php added

Also available in: Atom PDF