Bug #82852

Empty page with invalid config.metaCharset

Added by Mathias Brodala almost 2 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Code Cleanup
Target version:
Start date:
2017-10-25
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If an invalid value is set for config.metaCharset, the whole page output is dropped and an empty page is shown instead.

There was a workaround added (#81634) for cases like UTF-8 instead of utf-8 but there are millions of ways of doing it wrong, e.g. utf8 instead of utf-8.

Instead of silently dropping the page content without notice, an error should be thrown which clearly hints at the error.


Related issues

Related to TYPO3 Core - Bug #81634: No output in FE of 8.7.2 due to config.metaCharset = UTF-8 Closed 2017-06-15 2017-06-15

Associated revisions

Revision bd4a35ea (diff)
Added by Mathias Brodala almost 2 years ago

[!!!][BUGFIX] Throw exception on invalid charset

This gives users a clear hint if e.g. config.metaCharset contains
an invalid value instead of showing a blank page.

Change-Id: I9cdb37cc7e61af10e2d1985ef43f488e53b17a48
Resolves: #82852
Releases: master, 8.7
Reviewed-on: https://review.typo3.org/54471
Tested-by: TYPO3com <>
Reviewed-by: Frank Naegler <>
Reviewed-by: Wolfgang Klinger <>
Tested-by: Riccardo De Contardi <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Stefan Neufeind <>
Tested-by: Stefan Neufeind <>

Revision 016054de (diff)
Added by Stefan Neufeind almost 2 years ago

[TASK] Log warning on invalid charset

This gives users a clear hint if e.g. config.metaCharset contains
an invalid value instead of showing a blank page.

Change-Id: I9cdb37cc7e61af10e2d1985ef43f488e53b17a48
Resolves: #82852
Releases: master, 8.7
Reviewed-on: https://review.typo3.org/54503
Reviewed-by: Mathias Brodala <>
Tested-by: TYPO3com <>
Tested-by: Pawel Cieslik <>
Reviewed-by: Pawel Cieslik <>
Reviewed-by: Stefan Neufeind <>
Tested-by: Stefan Neufeind <>

History

#1 Updated by Mathias Brodala almost 2 years ago

  • Related to Bug #81634: No output in FE of 8.7.2 due to config.metaCharset = UTF-8 added

#2 Updated by Gerrit Code Review almost 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54471

#3 Updated by Gerrit Code Review almost 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54471

#4 Updated by Gerrit Code Review almost 2 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54503

#5 Updated by Mathias Brodala almost 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Gerrit Code Review almost 2 years ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54503

#7 Updated by Gerrit Code Review almost 2 years ago

Patch set 3 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54503

#8 Updated by Gerrit Code Review almost 2 years ago

Patch set 4 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54503

#9 Updated by Stefan Neufeind almost 2 years ago

  • Status changed from Under Review to Resolved

#10 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF