Bug #83066

Translation Metadata can't be deleted

Added by Markus no-lastname-given about 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2017-11-22
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If you create translated metadata for a file (edit metadata in default language, then click the flag symbol for any other installed language in list view), there is no easy way of deleting the created record again.

Only way I found was to select the records history and 'reverse' the creation of the record. If for some reason the history functionality is not available, there is no way of deleting translated meta data.


Related issues

Related to TYPO3 Core - Bug #71678: Remove delete icon in toolbar for sys_file_metadataClosedMichael Oehlhof2015-11-19

Actions
#1

Updated by Wolfgang Klinger about 3 years ago

  • Related to Bug #71678: Remove delete icon in toolbar for sys_file_metadata added
#2

Updated by Gerrit Code Review about 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55340

#3

Updated by Gerrit Code Review about 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55340

#4

Updated by Gerrit Code Review about 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55340

#5

Updated by Anja Leichsenring about 3 years ago

Deletion of sys_file_metadata records in default language has been prevented through the interface, because these records are created on the fly upon accessing the file record, so the deletion by user just made no sense. In this process, ALL deletion of sys_file_metadata records has been blocked, so the situation of non deletable translations occurred.
By checking the sys_language_uid of the record, this issue can be avoided. Users should be able to delete translations of sys_file_metadata records (but still not the default language ones).

#6

Updated by Gerrit Code Review about 3 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55354

#7

Updated by Wolfgang Klinger about 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#8

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF