Bug #83160

Remove unused column sys_file_reference.sorting

Added by Stephan Großberndt over 1 year ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Category:
File Abstraction Layer (FAL)
Target version:
Start date:
2017-11-29
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:
Remote Sprint

Description

In issue #80800 column sys_file_reference.sorting was disabled in order to be a non-breaking for TYPO3 8.7

Since the column is no longer used remove it on master (v9)


Related issues

Related to TYPO3 Core - Bug #80800: Too many records on sys_file_reference table breaks TYPO3 when saving IRRE records Closed 2017-04-10
Related to TYPO3 Core - Task #83286: Improve hardcoded tablenames in RelationHandler.php Closed 2017-12-11

Associated revisions

Revision 728bfc19 (diff)
Added by Stephan Großberndt over 1 year ago

[!!!][TASK] Remove column sys_file_reference.sorting

The column `sorting` has been removed from table `sys_file_reference` as
it was not used in TYPO3 core and lead to severe performance issues on
instances with many records in the table.

Releases: master
Resolves: #83160
Related: #80800
Change-Id: Ibff4e11f2ab3954a71cf0ef86e4a75ec4f39eb8c
Reviewed-on: https://review.typo3.org/54858
Tested-by: TYPO3com <>
Reviewed-by: Mathias Schreiber <>
Tested-by: Mathias Schreiber <>
Reviewed-by: Stefan Neufeind <>
Tested-by: Stefan Neufeind <>

Revision 957082fc (diff)
Added by Oliver Hader over 1 year ago

[FOLLOWUP][TASK] Remove column sys_file_reference.sorting

Table sys_file_reference is used as "inline 1:n foreign_field" composite
assiciation and is processed in RelationHandler methods readForeignField
and writeForeignField. Albeit it looks like an MM table it still is a
regular TCA table being used as an entity with further attributes.

That's why this follow-up reverts the changes in file RelationHandler.php
that have been introduced in 728bfc194f46651ac70725d8aa6b476dac777765.

Related: #83160
Releases: master
Change-Id: I4b7a78a0ee494af9492996e81c2b631c29832cc6
Reviewed-on: https://review.typo3.org/55107
Tested-by: TYPO3com <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>
Reviewed-by: Stephan Großberndt <>
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

History

#1 Updated by Stephan Großberndt over 1 year ago

  • Related to Bug #80800: Too many records on sys_file_reference table breaks TYPO3 when saving IRRE records added

#2 Updated by Gerrit Code Review over 1 year ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54858

#3 Updated by Gerrit Code Review over 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54858

#4 Updated by Gerrit Code Review over 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54858

#5 Updated by Gerrit Code Review over 1 year ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54858

#6 Updated by Gerrit Code Review over 1 year ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54858

#7 Updated by Gerrit Code Review over 1 year ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54858

#8 Updated by Gerrit Code Review over 1 year ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54858

#9 Updated by Stefan Neufeind over 1 year ago

  • Related to Task #83286: Improve hardcoded tablenames in RelationHandler.php added

#10 Updated by Stephan Großberndt over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#11 Updated by Benni Mack 8 months ago

  • Status changed from Resolved to Closed

#12 Updated by Patrick Broens about 2 months ago

  • Related to Bug #88134: Lots a database queries to sys_refindex cause slow page saving added

#13 Updated by Patrick Broens about 2 months ago

  • Related to deleted (Bug #88134: Lots a database queries to sys_refindex cause slow page saving)

Also available in: Atom PDF