Bug #83165

Editing file metadata of translated tt_content

Added by Sebastian Fischer about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
Start date:
2017-11-29
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I try to edit the metadata of a translated tt_content element. When clicking on the edit button of the image inline element i get a fatal error with the message:

#1437656456: $uid must be positive integer, 0 given

This happens when there is no file metadata translation created previously.

While i know why this happens a regular editor will not understand it that easily. The expected behaviour is:

a either create a translation of the file metadata on clicking the edit button
b or do not show the edit button at all but render a + button to add the translation

Having neither of these solutions leads to bad ux


Related issues

Duplicates TYPO3 Core - Bug #76262: "$uid must be positive integer, 0 given" when trying to edit file metadata Closed 2016-05-23
Duplicates TYPO3 Core - Bug #82178: \TYPO3\CMS\Backend\Form\Container\InlineRecordContainer::renderForeignRecordHeaderControl wrong edit link Closed 2017-08-23

History

#1 Updated by Mathias Schreiber about 2 years ago

  • Status changed from New to Closed

dupe

#2 Updated by Mathias Brodala about 2 years ago

  • Duplicates Bug #76262: "$uid must be positive integer, 0 given" when trying to edit file metadata added

#3 Updated by Mathias Schreiber about 2 years ago

  • Duplicates Bug #82178: \TYPO3\CMS\Backend\Form\Container\InlineRecordContainer::renderForeignRecordHeaderControl wrong edit link added

Also available in: Atom PDF