Project

General

Profile

Actions

Bug #82178

closed

\TYPO3\CMS\Backend\Form\Container\InlineRecordContainer::renderForeignRecordHeaderControl wrong edit link

Added by Marcos Fadul over 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2017-08-23
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:
On Location Sprint

Description

The $recordInDatabase in line 506 is false if no metadata for the file exist. This produce a wrong edit link where uid is null. This can be fix by adding a check on $recordInDatabase in the if condition on line 522.
if ($recordInDatabase && $backendUser->check('tables_modify', 'sys_file_metadata')) {


Related issues 3 (1 open2 closed)

Related to TYPO3 Core - Bug #92906: File Metadata are not editable when translation doesn't exist yetNew2020-11-23

Actions
Is duplicate of TYPO3 Core - Bug #76262: "$uid must be positive integer, 0 given" when trying to edit file metadataClosed2016-05-23

Actions
Has duplicate TYPO3 Core - Bug #83165: Editing file metadata of translated tt_contentClosed2017-11-29

Actions
Actions #1

Updated by Łukasz Uznański about 6 years ago

  • Sprint Focus set to On Location Sprint
Actions #2

Updated by Gerrit Code Review about 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54778

Actions #3

Updated by Gerrit Code Review about 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54778

Actions #4

Updated by Gerrit Code Review about 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54778

Actions #5

Updated by Gerrit Code Review about 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54778

Actions #6

Updated by Mathias Brodala about 6 years ago

  • Is duplicate of Bug #76262: "$uid must be positive integer, 0 given" when trying to edit file metadata added
Actions #7

Updated by Gerrit Code Review about 6 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54822

Actions #8

Updated by Łukasz Uznański about 6 years ago

  • Status changed from Under Review to Resolved
Actions #9

Updated by Mathias Schreiber about 6 years ago

  • Has duplicate Bug #83165: Editing file metadata of translated tt_content added
Actions #10

Updated by Gerrit Code Review almost 6 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56568

Actions #11

Updated by Łukasz Uznański over 5 years ago

  • Status changed from Under Review to Resolved
Actions #12

Updated by Sebastian Michaelsen over 5 years ago

  • Status changed from Resolved to New

When a record is in a certain language (sys_language_uid > 0) it does not mean the meta data of a referenced file have to be translated into the same language.
When you work with separate files in different languages (e.g. PDFs) you will usually not have translated meta data records, you still should be able to access/edit them.

My proposal is to link to the according meta data translation if possible (as it is now) and link to the meta data in the default language if there is no matching translation.

Actions #13

Updated by Anja Leichsenring over 5 years ago

  • Status changed from New to Resolved

@Sebastian Kurfuerst, can you please open a new ticket to your issue? The issue described in the ticket has been resolved by the patches merged. You are welcome to set a relation to this one on the new ticket so we can easily follow up on the different stages the behavior went trough.

If you need a different behavior, please describe it in a little more detail than you did here, and do in a separate ticket. It's easier to keep track of the changes then.

Thanks a bunch.

I close this ticket again for the named reason.

Actions #14

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions #15

Updated by Sebastian Michaelsen about 3 years ago

  • Related to Bug #92906: File Metadata are not editable when translation doesn't exist yet added
Actions

Also available in: Atom PDF