Bug #83187

no title visible in file list module in backend for cut an copy and double quotation marks in typo3_src-7.6.23/typo3/sysext/filelist/Classes/FileList.php in 7.6

Added by Martin Clewing 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2017-12-01
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Version 7.6.23

File typo3_src-7.6.23/typo3/sysext/filelist/Classes/FileList.php

// not working in 7.6.x
$cutTitle = htmlspecialchars($this->getLanguageService()->sL('LLL:EXT:lang/Resources/Private/Language/locallang_core.xlf:cm.cut'));
// working in 7.6
$cutTitle = htmlspecialchars($this->getLanguageService()->sL('LLL:EXT:lang/locallang_core.xlf:cm.cut'));

// not working in 7.6
$copyTitle = htmlspecialchars($this->getLanguageService()->sL('LLL:EXT:lang/Resources/Private/Language/locallang_core.xlf:cm.copy'));
// working in 7.6
$copyTitle = htmlspecialchars($this->getLanguageService()->sL('LLL:EXT:lang/locallang_core.xlf:cm.copy'));

seems to be right for 8.7 but not yet for 7.6.23!

also: same issue as https://forge.typo3.org/issues/83186
double quotation marks in 2 occasions in that file

Associated revisions

Revision 85030908 (diff)
Added by Wouter Wolters 6 months ago

[BUGFIX] Fix wrong reference to language file in FileList class

During a backport of #80920 the file reference was not updated to
the right location.

Resolves: #83187
Releases: 7.6
Change-Id: I20637d1d1ee26f892084909c600cbe43a7c46a02
Reviewed-on: https://review.typo3.org/54900
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

History

#1 Updated by Michael Stucki 6 months ago

  • Project changed from forge.typo3.org to TYPO3 Core
  • TYPO3 Version set to 9

#2 Updated by Michael Stucki 6 months ago

  • TYPO3 Version changed from 9 to 7

#3 Updated by Gerrit Code Review 6 months ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54900

#4 Updated by Gerrit Code Review 6 months ago

Patch set 2 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/54900

#5 Updated by Wouter Wolters 6 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF