Bug #83333

Missing required (but unused) argument for DataHandler::printLogErrorMessages()

Added by Mathias Brodala 8 months ago. Updated 8 months ago.

Status:
Resolved
Priority:
Should have
Category:
Backend API
Target version:
Start date:
2017-12-14
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The method FormInlineAjaxController::synchronizeLocalizeAction() calls DataHandler::printLogErrorMessages() without its required argument.

However, this would be perfectly fine since that argument is not used in that method anyways. For master and v9 this has been fixed recently through #82629 but at least this part should be applied to v8 too.


Related issues

Related to TYPO3 Core - Task #82629: Remove tce_db options "prErr" and "uPT" Resolved 2017-10-01
Related to TYPO3 Core - Bug #85762: DataHandler::printLogErrorMessages() - v7.6 lts Needs Feedback 2018-08-06

Associated revisions

Revision 82482dbd (diff)
Added by Mathias Brodala 8 months ago

[BUGFIX] Drop unused DataHandler::printLogErrorMessages() argument

The argument can be safely dropped since it is not used in the
method anyways.

Resolves: #83333
Related: #82629
Releases: 8.7
Change-Id: I7ede9c58f454d887d9313163988a50c8b31d9846
Reviewed-on: https://review.typo3.org/55078
Tested-by: TYPO3com <>
Reviewed-by: Wolfgang Klinger <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

History

#1 Updated by Mathias Brodala 8 months ago

  • Related to Task #82629: Remove tce_db options "prErr" and "uPT" added

#2 Updated by Gerrit Code Review 8 months ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55078

#3 Updated by Mathias Brodala 8 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Marco von Arx 13 days ago

  • Related to Bug #85762: DataHandler::printLogErrorMessages() - v7.6 lts added

Also available in: Atom PDF