Bug #85762

DataHandler::printLogErrorMessages() - v7.6 lts

Added by Marco von Arx over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
-- undefined --
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-08-06
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
7.1
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

The issue was fixed for v8 and published with v8.7.10.

According to the chart at https://typo3.org/cms/roadmap/ we would expect that typo3 v7.6 lts supports PHP v7.1 which it currently does not because of the printLogErrorMessages().
An ArgumentCountError exception will be thrown on PHP v7.1
http://php.net/manual/de/class.argumentcounterror.php

History

#1 Updated by Marco von Arx over 1 year ago

  • Related to Bug #83333: Missing required (but unused) argument for DataHandler::printLogErrorMessages() added

#2 Updated by Tymoteusz Motylewski over 1 year ago

  • Status changed from New to Needs Feedback

Hi Marco
Thanks for your report.
Can you please describe how the issue can be fixed, or even better provide a patch (and push it to review.typo3.org).
Thanks

#3 Updated by Marco von Arx about 1 year ago

Hi Tymoteusz

I think we could apply the same changes from changeset https://forge.typo3.org/projects/typo3cms-core/repository/revisions/82482dbd65f5b5e531b6bac0f771f4ae38a87681

however, line numbers may vary.

Or we can make $redirect argument optional like

public function printLogErrorMessages($redirect = '')

(in file typo3/sysext/core/Classes/DataHandling/DataHandler.php)

Regards

#4 Updated by Benni Mack about 1 year ago

Hey Marco,

I don't know how to reproduce this. printLogErrorMessages() in TYPO3 v7 Core is always called with an argument, so how is this a PHP 7.2 error?

Thanks for some clarification. I'd like to fix this, but I'm unable to reproduce (and running various v7 installations on PHP 7.2 without finding an issue in this area).

#5 Updated by Marco von Arx about 1 year ago

Hi Benni

I did check again with v7.6 sources and could not reproduce it either. In fact printLogErrorMessages is always called with a non empty parameter as you mentioned in your reply.
I must have confused the source codes at the time i have opened the ticket.

I'm sorry for any inconveniences and will close this ticket.

Regards

#6 Updated by Marco von Arx about 1 year ago

  • Priority changed from Must have to -- undefined --

#7 Updated by Marco von Arx about 1 year ago

  • Related to deleted (Bug #83333: Missing required (but unused) argument for DataHandler::printLogErrorMessages())

#8 Updated by Riccardo De Contardi about 1 year ago

  • Status changed from Needs Feedback to Closed

Hi Marco, I hope it is fine for you if I close this ticket; If I have understood it wrong, please ping me and I'll reopen it. Thank you.

Also available in: Atom PDF