Bug #83648

Emptying datetime causes SQL error

Added by Rudy Gnodde over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2018-01-23
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When I empty a datetime field in the backend and try to save the record I get an SQL error when MySQL is in strict mode: Incorrect integer value: ''

Steps to reproduce:

1. Create a new fe_users record with starttime set
2. Save the record
3. Empty the starttime field
4. Save the record


Related issues

Is duplicate of TYPO3 Core - Bug #82756: Can't remove access starttime / endtimeClosed2017-10-13

Actions
#1

Updated by Andre Koller over 3 years ago

I can confirm that in v8.7.9

2: SQL error: 'Incorrect integer value: '' for column 'starttime' at row 1' (fe_users:1)

#2

Updated by Susanne Moog over 3 years ago

  • Category set to FormEngine aka TCEforms
#3

Updated by Wouter Wolters over 3 years ago

  • Is duplicate of Bug #82756: Can't remove access starttime / endtime added
#4

Updated by Wouter Wolters over 3 years ago

  • Status changed from New to Closed

I'm closing this ticket because it is a duplicate of #82756
Please continue there. Thanks.

Also available in: Atom PDF