Bug #83705

NewContentElementWizardHookInterface gets new parentObject

Added by Nicole Cordes over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
-
Target version:
Start date:
2018-01-28
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Given:

A class that implemented the NewContentElementWizardHookInterface and wants to change wizardItems.

Expected:

As documented in the NewContentElementWizardHookInterface the hook object should get a parent object of class \Controller\ContentElement\NewContentElementController

Actual:

Due to change https://review.typo3.org/52999/ the hook gets a parentObject of type \TYPO3\CMS\Backend\Controller\Wizard\NewContentElementWizardController instead. As property visibilities changed, this change is unfortunately breaking.


Related issues

Related to TYPO3 Core - Feature #75676: Choose position and then content element type Closed 2016-04-15
Related to TYPO3 Core - Bug #83523: remove or deprecate NewContentElementController Rejected 2018-01-09

Associated revisions

Revision 8bff8c83 (diff)
Added by Oliver Hader over 2 years ago

[BUGFIX] NewContentElementWizardController to NewContentElementController

NewContentElementWizardController, which has been introduced for TYPO3 v9
to render the new content element process in a dedicated modal was just a
duplicate of the existing NewContentElementController class with some
minor adjustments and code flow enhancements (names, empty checks).

However, there have been several side effects like:
  • hook implementing NewContentElementWizardHookInterface would have been
    called by both object instances, having different public properties -
    the most common access to $parentObject->id or ~->sys_language would
    have failed to to property visibility and change names
  • the JavaScript closure callback to adjust the URL when interacting in
    the browser was hard-coded to modal rendering, with still having the
    possibility to render the old behavior e.g. in the web>list view

To overcome these flaws both mentioned classes have been merged since the
functionality was not that much different anyway. Besides that different
JavaScript client scopes ('window' or 'list_frame') are forwarded to the
according object instances.

Resolves: #83705
Releases: master
Change-Id: I472a7ec8a5d06c05e6c7053bf98b5cfacb69f9d9
Reviewed-on: https://review.typo3.org/55479
Tested-by: TYPO3com <>
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>

History

#1 Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55477

#2 Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55477

#3 Updated by Oliver Hader over 2 years ago

  • Is Regression set to Yes

#4 Updated by Oliver Hader over 2 years ago

  • Related to Feature #75676: Choose position and then content element type added

#5 Updated by Oliver Hader over 2 years ago

Cannot access protected property TYPO3\CMS\Backend\Controller\Wizard\NewContentElementWizardController::$id 

#6 Updated by Oliver Hader over 2 years ago

  • Priority changed from Should have to Must have

#7 Updated by Gerrit Code Review over 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55477

#8 Updated by Oliver Hader over 2 years ago

  • Related to Bug #83523: remove or deprecate NewContentElementController added

#9 Updated by Gerrit Code Review over 2 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55479

#10 Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55479

#11 Updated by Gerrit Code Review over 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55479

#12 Updated by Gerrit Code Review over 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55479

#13 Updated by Gerrit Code Review over 2 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55479

#14 Updated by Oliver Hader over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#16 Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF