Bug #83729

Revert FalYamlParser for TYPO3 v9.1

Added by Oliver Hader over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
Start date:
2018-01-30
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

While the intended feature is great (having the possiblity to extract and re-use parts of the form definition), implementation wise it needs some rework.
To be able to release 9.1 as stable as possible, we now revert this implementation for now and bring it in for 9.2 again.

Associated revisions

Revision 160f8db6 (diff)
Added by Helmut Hummel over 1 year ago

Revert "[FEATURE] EXT:form - introduce YAML "imports""

While the intended feature is great (having the possiblity
to extract and re-use parts of the form definition),
implementation wise it needs some rework.

To be able to release 9.1 as stable as possible,
we now revert this implementation for now
and bring it in for 9.2 again.

This reverts commit a52a99220ca24251186ea88d11b3db43436a8156.

Reverts: #82089
Resolves: #83729
Releases: master
Change-Id: I850401d232b642e712801613d3780816f873966a
Reviewed-on: https://review.typo3.org/55422
Tested-by: TYPO3com <>
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

History

#1 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55422

#2 Updated by Oliver Hader over 1 year ago

  • Subject changed from Revert FalYamlParse for TYPO3 v9.1 to Revert FalYamlParser for TYPO3 v9.1

#3 Updated by Helmut Hummel over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF