Project

General

Profile

Actions

Bug #83750

closed

InlineControlContainer disrespects GeneralUtility::callUserFunction's signature

Added by Olaf Hoffmann over 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Category:
Backend API
Target version:
Start date:
2018-02-01
Due date:
% Done:

100%

Estimated time:
2.00 h
TYPO3 Version:
8
PHP Version:
7.1
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

The variable `$customControlConfig` is an array:

https://github.com/TYPO3/TYPO3.CMS/blob/v9.1.0/typo3/sysext/backend/Classes/Form/Container/InlineControlContainer.php#L333

GeneralUtility::callUserFunction however expects its first argument to be a string or a function but not an array:

https://github.com/TYPO3/TYPO3.CMS/blob/v9.1.0/typo3/sysext/core/Classes/Utility/GeneralUtility.php#L3388

This breaks the `customControls` feature of inline-Fields in TCA as documented here: https://docs.typo3.org/typo3cms/TCAReference/8.7/ColumnsConfig/Type/Inline.html#customcontrols

Instead of passing an array of arrays as requested by the docs, one could just pass an array of functions and/or function identifiers to work around this issue.

Tested with TYPO3 versions 8 and 9.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Task #85913: Remove deprecation backported to v8ClosedAnja Leichsenring2018-08-20

Actions
Actions #1

Updated by Xavier Perseguers almost 6 years ago

  • Status changed from New to Accepted
  • Assignee set to Xavier Perseguers

In fact, the documentation is wrong, probably since TYPO3 v4.7. I can reproduce this bug in TYPO3 7.6 and code is still wrong on master branch.

Actions #2

Updated by Gerrit Code Review almost 6 years ago

  • Status changed from Accepted to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57525

Actions #3

Updated by Gerrit Code Review almost 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57525

Actions #4

Updated by Gerrit Code Review almost 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57525

Actions #5

Updated by Gerrit Code Review almost 6 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57525

Actions #6

Updated by Gerrit Code Review almost 6 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57525

Actions #7

Updated by Gerrit Code Review almost 6 years ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57817

Actions #8

Updated by Xavier Perseguers almost 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #9

Updated by Anja Leichsenring almost 6 years ago

  • Related to Task #85913: Remove deprecation backported to v8 added
Actions #10

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF