Bug #83816

CE table empties cells with "0" in it

Added by Johannes C. Schulz over 2 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Fluid Styled Content
Start date:
2018-02-09
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Today I migrated a page from 7.6 and CSC to 8.7 and FSC. There were many CE table on that page looking like that (these are schedules):

|Mittwoch|Donnerstag|Freitag

Uhr|||

10||00|50

12||00|50

14|00|50|50

16|00|50|

18|00|50|

20|00|50|

With CSC all was fine, but with FSC all cells with "00" will be emptied! I have to prepand a sign (like ":", but not ".") to prevent emptiing of the cells.
I tried to investigate where the cells are beeing emptied, maybe somewhere in CsvUtility, but I don't know.

Associated revisions

Revision c75a9066 (diff)
Added by Georg Ringer 8 months ago

[BUGFIX] Show value '0' in cells of table content element

Adjust the check of the value to make it also possible
to show the valid cell value '0' of content element table.

Resolves: #83816
Releases: master, 9.5
Change-Id: Ie2f8d30b02deda5be88824cef334bf672d5cb35e
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/63684
Reviewed-by: Markus Klein <>
Reviewed-by: Oliver Bartsch <>
Reviewed-by: Stefan Froemken <>
Reviewed-by: Andreas Fernandez <>
Tested-by: TYPO3com <>
Tested-by: Oliver Bartsch <>
Tested-by: Stefan Froemken <>
Tested-by: Andreas Fernandez <>

Revision 8f3ce896 (diff)
Added by Georg Ringer 8 months ago

[BUGFIX] Show value '0' in cells of table content element

Adjust the check of the value to make it also possible
to show the valid cell value '0' of content element table.

Resolves: #83816
Releases: master, 9.5
Change-Id: Ie2f8d30b02deda5be88824cef334bf672d5cb35e
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/63691
Tested-by: Oliver Bartsch <>
Tested-by: TYPO3com <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Oliver Bartsch <>
Reviewed-by: Andreas Fernandez <>

History

#1 Updated by Johannes C. Schulz over 2 years ago

  • Description updated (diff)

#2 Updated by Riccardo De Contardi almost 2 years ago

Still reproducible on 9.5.2-dev (latest master)

#3 Updated by Benni Mack over 1 year ago

  • Target version changed from next-patchlevel to Candidate for patchlevel

#4 Updated by Georg Ringer 8 months ago

  • Description updated (diff)

#5 Updated by Gerrit Code Review 8 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63684

#6 Updated by Gerrit Code Review 8 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63684

#7 Updated by Gerrit Code Review 8 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63684

#8 Updated by Georg Ringer 8 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Gerrit Code Review 8 months ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63691

#10 Updated by Gerrit Code Review 8 months ago

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63691

#11 Updated by Georg Ringer 8 months ago

  • Status changed from Under Review to Resolved

#12 Updated by Benni Mack 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF