Bug #83859

stdwrap.round is not working

Added by Christian Stern over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
TypoScript
Target version:
Start date:
2018-02-12
Due date:
% Done:

100%

Estimated time:
1.00 h
TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

The following code (https://docs.typo3.org/typo3cms/TyposcriptReference/Functions/Round/Index.html) is not working in TYPO3 8.7.1 and 8.7.10.

page = PAGE
page.1 = TEXT
page.1 {
  value = 3.14159

  stdWrap.round.roundType = round
  stdWrap.round.decimals = 2
}

Output:

3.14159

I tested all available settings: floor, ceil and round

It does work in the latest TYPO3 7.6.

#1

Updated by Christian Stern over 3 years ago

  • Description updated (diff)
#2

Updated by Georg Ringer over 3 years ago

  • Status changed from New to Needs Feedback

this must be activated with round = 1, works fine, at least tested with master.

is that ok for you?

#3

Updated by Christian Stern over 3 years ago

Georg Ringer wrote:

this must be activated with round = 1, works fine, at least tested with master.

is that ok for you?

Yep, it is. Thanks!

So it seems that round needs a round = 1 since 8.7. I corrected the documentation: https://github.com/TYPO3-Documentation/TYPO3CMS-Reference-Typoscript/pull/135

#4

Updated by Christian Stern over 3 years ago

  • % Done changed from 0 to 100
#5

Updated by Georg Ringer over 3 years ago

  • Status changed from Needs Feedback to Resolved
#6

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF