Bug #83892

The duplicate button is visible also if it makes no sense

Added by Frank Naegler over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Backend User Interface
Target version:
Start date:
2018-02-14
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In some cases, the duplicate button makes no sense and will break the database consistency:

Currently the new "duplicate" button if editing record:
  • creates funny results if 'duplicating' a localized record (there must not be 2 localized records in the same language for one parent record)
  • it does not respect the "copy/translate" mode and allows to create a dupe of a localized record in translate mode
  • maybe more?

Related issues

Related to TYPO3 Core - Feature #77685: Create a save and open copy button when saving a content elementClosed2016-08-30

Actions
Related to TYPO3 Core - Bug #83926: Language related fields for the "Duplicate" button are hardcodedClosedAndreas Fernandez2018-02-15

Actions
#1

Updated by Frank Naegler over 3 years ago

  • Related to Feature #77685: Create a save and open copy button when saving a content element added
#2

Updated by Gerrit Code Review over 3 years ago

  • Status changed from Accepted to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55713

#3

Updated by Gerrit Code Review over 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55713

#4

Updated by Frank Naegler over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Andreas Fernandez over 3 years ago

  • Related to Bug #83926: Language related fields for the "Duplicate" button are hardcoded added
#6

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF