Bug #83998

Field "advanced password" doesn't work correctly

Added by Sven Burkert 10 months ago. Updated 10 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2018-02-21
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I have a form with several form pages. On one page I have a text field "username" and an advanced password field "password".
I fill in username and the password two times and click on submit button. In about 1 from 10 attempts, the same page is displayed again, but with no error message. After trying some different username or password or reloading the page, everything is ok, the next form page is displayed.

Registration.yaml View - Form to test (6.13 KB) Sven Burkert, 2018-02-21 13:14

History

#1 Updated by Sven Burkert 10 months ago

Please use this form to test.
If the error doesn't occure on testing, go back one step (fill in username and password, submit form page, click form submit button "back" and try again with different username and password).

#2 Updated by Ralf Zimmermann 10 months ago

For now, i can't reproduce this.

Is it possible, that the honeypot field is filled for some reason?
Can you try to test it again with disabled honeypot, please?


type: Form
identifier: registration
label: 'Member Registration'
prototypeName: standard
renderingOptions:
  submitButtonLabel: 'Kostenpflichtig bestellen'
  honeypot:
    enable: false

#3 Updated by Ralf Zimmermann 10 months ago

  • Status changed from New to Needs Feedback
  • Assignee set to Sven Burkert

#4 Updated by Sven Burkert 10 months ago

  • Assignee changed from Sven Burkert to Ralf Zimmermann

You're right, it's the honeypot field! This field is filled (only sometimes) with the username I use for login for TYPO3 BE.
Thank you for your help! I will remove the honeypot for my form.

#5 Updated by Bjoern Jacob 10 months ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Ralf Zimmermann)

Please consider that removing this field could cause receiving spam/ more spam ;)

Thanks for your fast response.

Also available in: Atom PDF