Bug #84068

Install tool "clear processed file" gives error when using custom file drivers

Added by Frans Saris over 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
File Abstraction Layer (FAL)
Start date:
2018-02-27
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Currently the custom file driver registered by extensions are not loaded in Web/typo3/sysext/install/Classes/Controller/Action/Tool/CleanUp.php::clearProcessedFiles. This results in errors when you try to delete the processed files


Related issues

Is duplicate of TYPO3 Core - Bug #88970: Remove Temporary Assets doesn't remove processed files from 3rd party FAL driversClosedRichard Haeser2019-08-16

Actions
#1

Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55926

#2

Updated by Gerrit Code Review about 3 years ago

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/55926

#3

Updated by Benni Mack about 2 years ago

  • Target version changed from next-patchlevel to Candidate for patchlevel
#4

Updated by Daniel Goerz over 1 year ago

  • Is duplicate of Bug #88970: Remove Temporary Assets doesn't remove processed files from 3rd party FAL drivers added
#5

Updated by Daniel Goerz over 1 year ago

  • Status changed from Under Review to Closed

This has been fixed in master and 9.5 with #88970 and won't go into 8.7 anymore.

Also available in: Atom PDF