Bug #84079

Error after creating file containing spaces

Added by David Henninger over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2018-02-28
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
7.0
Tags:
space new file backend
Complexity:
Is Regression:
Sprint Focus:

Description

When creating a file containing spaces (like "hello world.txt"), Typo3 fails subsequently with the following error:

#1329647780: Object with identifier "1:/user_upload/hello world.txt" does not exist in storage

The file has been created, but the containing space has been replaced with an underscore. Thus "hello_world.txt" exists, but "hello world.txt" does not.


Files

error.png (26.1 KB) error.png Screenshot of the error message David Henninger, 2018-02-28 13:19

Related issues

Related to TYPO3 Core - Bug #84178: Cannot create but upload file with "@" in nameClosed2018-03-08

Actions
#1

Updated by David Henninger over 2 years ago

#2

Updated by Wolfgang Klinger over 2 years ago

  • Related to Bug #84178: Cannot create but upload file with "@" in name added
#3

Updated by Wolfgang Klinger over 2 years ago

This will be fixed (more obvious) with #84178.
Please test with the patch there.

#4

Updated by Riccardo De Contardi over 2 years ago

  • Category set to File Abstraction Layer (FAL)
#5

Updated by Riccardo De Contardi over 2 years ago

  • Status changed from New to Needs Feedback

#84178 has been merged.

I tried the following text with 8.7.16

1) go to filelist view, click on a folder
2) create a new txt file
3) choose as name "Hello spank.txt" (with the space)

Result:

the file has been created with name hello_spank.txt

No error, just a warning:

The file name "hello spank.txt" is invalid, the file was automatically renamed to "hello_spank.txt".

File created: "hello_spank.txt".

Do you think it is sufficient to consider this issue closed?

#6

Updated by David Henninger over 2 years ago

Riccardo De Contardi wrote:

#84178 has been merged.

Do you think it is sufficient to consider this issue closed?

Yes, that seems to be a good solution, tho allowing spaces within file names would also be very much welcomed, especially for files people download, just for improved readability.

Thanks for the heads up!

#7

Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Needs Feedback to Closed

Thank you for your feedback; I close this one for now;

If you think that this is the wrong decision or there is still work to be done on this topic please reopen it or open a new issue with a reference to this one.

Thank you.

Also available in: Atom PDF