Bug #84149

Avoid associative array to be used in LocalizationUtility

Added by Oliver Hader over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extbase
Target version:
Start date:
2018-03-06
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

On using associative array in LocalizationUtility which is e.g. used by Fluid's TranslateViewHelper, the error Cannot unpack array with string keys is thrown. The reason is that sprintf($value, ...$arguments) cannot be used with $arguments being an associative array.

The behavior can be reproduced in TYPO3 v9.2-dev when installing an extension in the extension manager that has e.g. insufficient version dependencies.


Related issues

Related to TYPO3 Core - Bug #63495: Depency popup window too small windows chrome Closed 2014-12-02
Related to TYPO3 Core - Task #82453: Extbase LocalizationUtility error feedback and logic can be improved Closed 2017-09-11

Associated revisions

Revision 60a68a50 (diff)
Added by Oliver Hader over 1 year ago

[BUGFIX] Avoid associative array to be used in LocalizationUtility

On using associative array in LocalizationUtility which is e.g. used
by Fluid's TranslateViewHelper, the error Cannot unpack array with
string keys is thrown. The reason is that sprintf($value, ...$arguments)
cannot be used with $arguments being an associative array.

Resolves: #84149
Releases: master
Change-Id: Ifb60338bcf9095954969221cf08bd7e3d141ecc2
Reviewed-on: https://review.typo3.org/56024
Tested-by: TYPO3com <>
Reviewed-by: Mathias Brodala <>
Tested-by: Mathias Brodala <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>

History

#1 Updated by Oliver Hader over 1 year ago

  • Related to Bug #63495: Depency popup window too small windows chrome added

#2 Updated by Oliver Hader over 1 year ago

  • Related to Task #82453: Extbase LocalizationUtility error feedback and logic can be improved added

#3 Updated by Oliver Hader over 1 year ago

  • Description updated (diff)

#4 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56024

#5 Updated by Oliver Hader over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF