Bug #84771

Links should not be rendered for pages that are hidden (due to language settings)

Added by Sybille Peters about 3 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2018-04-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If there is a link to a hidden page, this link is not rendered as a link (only the anchor text is displayed as plain text).

What I would expect

For any page that will not be visible in the current language (and causes a 404), the link should not be rendered as clickable link.

Current behaviour

The following are rendered as links:
  • Link target has "Hide default translation of page" set + default language
  • Link target has "Hide page if no translation for current language exists" set + use language for which page has no translation

Reproduce

  1. Make sure "Show hidden pages" is not selected in admin panel
  2. Create links for cases above and view page.

Files

forge.gif (577 KB) forge.gif Sybille Peters, 2019-03-26 13:37

Related issues

Related to TYPO3 Core - Bug #84538: Links to pages with setting "Hide default translation of page" should not be renderedClosed2018-03-27

Actions
#1

Updated by Sybille Peters about 3 years ago

  • Related to Bug #84538: Links to pages with setting "Hide default translation of page" should not be rendered added
#2

Updated by Benni Mack about 2 years ago

  • Status changed from New to Needs Feedback

Hi Sybille,

this is IMHO fixed in 9.5.5 - can you check if the issue is solved for you?

Thanks,
Benni.

#3

Updated by Sybille Peters about 2 years ago

This should be fixed now. See also #84538.

#4

Updated by Sybille Peters over 1 year ago

  • Status changed from Needs Feedback to Resolved
#5

Updated by Sybille Peters over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF