Bug #84538

Links to pages with setting "Hide default translation of page" should not be rendered

Added by Zsofia Gugan over 1 year ago. Updated 4 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Linkvalidator
Target version:
-
Start date:
2018-03-27
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When creating a link in the RTE to the default language version of a page with the setting "Language > Localization > Hide default translation of page", the link gets rendered and is also seen as valid when running the link validator.
As the default language version of the page is hidden, the link throws a 404.

The above mentioned setting should prevent creating the link in the frontend to the default language version of the target page and to a warning in the link validator module, just like when a page is hidden or deleted.

Tested in a vanilla installation of TYPO3 7.6.23 and 8.7.9


Related issues

Related to forge.typo3.org - Bug #84496: Links to pages with setting "Hide default translation of page" should not be rendered Closed 2018-03-20
Related to TYPO3 Core - Bug #84771: Links should not be rendered for pages that are hidden (due to language settings) Needs Feedback 2018-04-17

History

#1 Updated by Michael Stucki over 1 year ago

  • Related to Bug #84496: Links to pages with setting "Hide default translation of page" should not be rendered added

#2 Updated by Sybille Peters over 1 year ago

Zsofia, thanks for your report. I will try to clarify if this is a Linkvalidator problem or a link rendering problem.

  • If link rendering problem: The links should not be displayed if link target is invisible in current language
  • If Linkvalidator problem: I would have to check.

#3 Updated by Sybille Peters over 1 year ago

  • Related to Bug #84771: Links should not be rendered for pages that are hidden (due to language settings) added

#4 Updated by Benni Mack 5 months ago

  • Status changed from New to Needs Feedback

Can you please try this with v9.5.5 - we've reworked the functionality a lot.

#5 Updated by Beat Haenger 5 months ago

I tested this with TYPO3 9.5 LTS and TYPO3 8.7.22 LTS with regular page links (RTE) as well as with menu elements (menu_pages). When "Hide default translation of page" is active for a page, the link is not rendered and the site does not appear in the menu.

The link validator does not show the link as invalid, but since it is no longer an active link it does not need to be shown as invalid.

This is solved in my opinion.

#6 Updated by Zsofia Gugan 5 months ago

#7 Updated by Riccardo De Contardi 5 months ago

@Zsofia Gugan Thank you for your reply; do you think we can safely close this issue?

Thank you and best regards.

#8 Updated by Zsofia Gugan 4 months ago

Based on the infos above, the issue can be closed in my opiniion.

#9 Updated by Riccardo De Contardi 4 months ago

  • Status changed from Needs Feedback to Closed

Thank you for your reply; closing it as requested by the reporter.

If you think that this is the wrong decision or experience this issue again, then please reopen it or open a new issue with a reference to this one.

Thank you and best regards.

Also available in: Atom PDF