Bug #84831

localStorage icon caching breaks within the install tool

Added by Ralf Zimmermann about 1 year ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2018-04-20
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Open the developer console within chrome or firefox and watch the local storage.
Browse through some Modules and the icon markup will be stored within the local storage which is correct.
Now open the install tool "Analyze Database Structure" modal.
All local storage objects will be deleted and afterwards no icon markups will be stored again.


Related issues

Related to TYPO3 Core - Feature #84780: Store icons fetched by the Icon API in localStorage Closed 2018-04-18

History

#1 Updated by Ralf Zimmermann about 1 year ago

  • Related to Feature #84780: Store icons fetched by the Icon API in localStorage added

#2 Updated by Andreas Fernandez about 1 year ago

  • Status changed from New to Rejected

This kinda works as intended. The icon cache hash is different in the Install Tool as the TCA is not loaded in the first place. The icons of the page tree (that was our actual test case) don't get stored again as the DOM is still available in the browser, thus no new request is fired.

Also available in: Atom PDF