Bug #84838

Empty AdditionalConfiguration.php breaks install tool

Added by Guido Schmechel over 1 year ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
Start date:
2018-04-22
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If you add an "empty" AdditionalConfiguration.php with only one line, "

/install.php?install[controller]=layout&install[context]=backend&install[action]=executeSilentConfigurationUpdate&_=1524415847672 add this one line to the JsonResponse. Backend response "Something went wrong. Please use Check for broken extensions to see if a loaded extension breaks this part of the install tool and unload it." in the view.


Related issues

Related to TYPO3 Core - Bug #82349: Install Tool "Configure Global Settings" bugs Closed 2017-09-07

History

#1 Updated by Guido Schmechel over 1 year ago

  • Related to Bug #82349: Install Tool "Configure Global Settings" bugs added

#2 Updated by Guido Schmechel over 1 year ago

Addition. The single line is:

<?php

This bug only appears 9.3-dev. 8.7.13 isn't affected.

#3 Updated by Georg Ringer over 1 year ago

  • Status changed from New to Needs Feedback

how to reproduce?

#4 Updated by Guido Schmechel over 1 year ago

Hi Georg,

i saved the file AdditionalConfiguration.php in the typo3conf folder. The content of this file is just the single line with an open php tag:

<?php

After that just click to a section of the new install tool.

#5 Updated by Christian Kuhn about 1 year ago

I'm unable to reproduce this in current master.

#6 Updated by Riccardo De Contardi about 1 year ago

I am actually able to reproduce it, with the latest master. My procedure:

1) create the file AdditionalConfiguration.php
2) write in it:

<?php

important: write exactly these characters, don't add anything else

- if you are outside the TYPO3 Backend, when you call the Install Tool, you get an empty page
- if you are inside the Backend and click on any of the Install Tool icons, you get the error:

Something went wrong. Please use Check for broken extensions to see if a loaded extension breaks this part of the install tool and unload it.

Note that:

- There are no php errors
- The error occurs only when the AdditionalConfiguration.php does not contain a space or a new line after those characters so, if you just write <?php or prepend a space, the error occurs; if you add a space or a line after <?php, the error does occur.

#7 Updated by Christian Kuhn about 1 year ago

  • Status changed from Needs Feedback to Rejected

Confirmed now, but imho not a bug of our application:

The start tag for php is

<?php[whitespace]

where [whitespace] is usually a line break.

Having a file without a line break or white space after

'<?php'

is invalid PHP, the code is interpreted as text only.

See the comments on http://php.net/manual/en/language.basic-syntax.phptags.php for more details on this.

You simply have to provide "valid" php code in this file, similar to a parse error or missing access permissions: That would make the Application fail, too.

According to my tests, the install tool works if you add

'<?php\n'

as file content.

Also available in: Atom PDF