Bug #84866

Installtool: Deactivate fe_typo_user cookie

Added by Joe Jones over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2018-04-25
Due date:
2018-05-25
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Dear core developers,

once it was possible to deactivate,that TYPO3 sets the cookie fe_typo_user. The cookie is, as war as I know, only usefull for frontend user login. Most sites do not have that feature. From May, 25th all websites need a new data privicy policy. That includes a list of cookies and their need. It would be a big affort, not needing this passus. Maybe you could bring back the option in the install tool.

Thank you for your work
Martin

History

#1 Updated by Benni Mack over 1 year ago

Hey Joe,

AFAIK since TYPO3 6.2 the cookie is not set anymore, only if you actively store something in a session (e.g. in a form or to log-in), then it is sent.

We use that new default behaviour very much so we can easily create CDN-cached pages from any TYPO3 rendered output if no user session (cart/basket or login area) is used.

#2 Updated by Joe Jones over 1 year ago

Hallo Benni,

thanks for the quick answer. At the moment I am working on a website that was updaten from an earlier state. Maybe that is the reason, that fe_typo3_user is set. I will check this on the next fresh installation.

Bye
Martin

#3 Updated by Georg Ringer over 1 year ago

  • Status changed from New to Needs Feedback

#4 Updated by Joe Jones over 1 year ago

Hi Benni,

sorry, you are right. I checked multiple TYPO3-Installations. Indeed they do not set cookies any more. Thanks you. Helps a lot.

Bye
Martin

#5 Updated by Wouter Wolters over 1 year ago

  • Status changed from Needs Feedback to Closed

Also available in: Atom PDF