Bug #84973

Cannot delete invalid Scheduler task

Added by Mathias Brodala over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
scheduler
Target version:
Start date:
2018-05-11
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When trying to delete an invalid Scheduler task (e.g. due to the related code being removed) an error occurs:

Fatal error: TYPO3\CMS\Scheduler\Scheduler::isValidTaskObject(): The script tried to execute a method or access a property of an incomplete object. Please ensure that the class definition &quot;<Task>&quot; of the object you are trying to operate on was loaded _before_ unserialize() gets called or provide a __autoload() function to load the class definition in /.../typo3/sysext/scheduler/Classes/Scheduler.php on line 449

Related issues

Related to TYPO3 Core - Bug #66587: Scheduler serialized task needs to be migrated for 7.x Closed 2015-04-25

Associated revisions

Revision 28b65ab8 (diff)
Added by Mathias Brodala over 1 year ago

[BUGFIX] Fix deletion of invalid tasks

If the class of a registered task is missing, e.g. because the related
extension has been removed, the task itself will be unserialized into
an __PHP_Incomplete_Class object. Checking the task execution is an
invalid access in this case and must be avoided for such tasks to be
deleted.

Resolves: #84973
Releases: master, 8.7
Change-Id: Iaec8a5e346a0d6257a942cbead50b214036ed700
Reviewed-on: https://review.typo3.org/56959
Reviewed-by: Wouter Wolters <>
Tested-by: TYPO3com <>
Reviewed-by: Frank Naegler <>
Tested-by: Frank Naegler <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

Revision 44a4e260 (diff)
Added by Mathias Brodala over 1 year ago

[BUGFIX] Fix deletion of invalid tasks

If the class of a registered task is missing, e.g. because the related
extension has been removed, the task itself will be unserialized into
an __PHP_Incomplete_Class object. Checking the task execution is an
invalid access in this case and must be avoided for such tasks to be
deleted.

Resolves: #84973
Releases: master, 8.7
Change-Id: Iaec8a5e346a0d6257a942cbead50b214036ed700
Reviewed-on: https://review.typo3.org/56973
Tested-by: TYPO3com <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Christian Kuhn over 1 year ago

didn't we fix this or a very similar thing recently?

#2 Updated by Mathias Brodala over 1 year ago

Christian Kuhn wrote:

didn't we fix this or a very similar thing recently?

I'll check once more, just wanted to be sure there's a ticket.

#3 Updated by Mathias Brodala over 1 year ago

  • Related to Bug #66587: Scheduler serialized task needs to be migrated for 7.x added

#4 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56959

#5 Updated by Gerrit Code Review over 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56959

#6 Updated by Gerrit Code Review over 1 year ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/56973

#7 Updated by Mathias Brodala over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF