Bug #85168

Language synchronization fails for inline relations within inline relations

Added by Florian Wessels 12 months ago. Updated 6 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Localization
Target version:
-
Start date:
2018-06-06
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The synchronization process will fail for synchronizing inline relations within inline relations when there are more than one language which should be synchronized from default or source language. Following error occures:

#1486233164: Child record was not processed

TCA of the main object:

[...]
'columns' => [
    'products' => [
        'exclude' => false,
        'label' => 'LLL:EXT:my_ext/Resources/Private/Language/locallang_db.xlf:tx_myext_domain_model_productwrapper.products',
        'config' => [
            'type' => 'inline',
            'foreign_table' => 'tx_myext_domain_model_product',
            'foreign_field' => 'productwrapper',
            'foreign_sortby' => 'sorting',
            'maxitems' => 9999,
            'appearance' => [
                'collapseAll' => true,
                'levelLinksPosition' => 'top',
                'showSynchronizationLink' => 1,
                'showPossibleLocalizationRecords' => 1,
                'showAllLocalizationLink' => 1,
                'useSortable' => true,
                'expandSingle' => 1,
                'enabledControls' => [
                    'sort' => true,
                    'delete' => true,
                    'hide' => true,
                    'localize' => true,
                    'dragdrop' => true,
                ],
            ],
        ],
    ],
]

TCA of inline element:

'columns' => [
    'images' => [
        'exclude' => false,
        'label' => 'LLL:EXT:my_ext/Resources/Private/Language/locallang_db.xlf:tx_myext_domain_model_product.images',
        'config' => \TYPO3\CMS\Core\Utility\ExtensionManagementUtility::getFileFieldTCAConfig(
            'images',
            [
                'appearance' => [
                    'createNewRelationLinkTitle' => 'LLL:EXT:frontend/Resources/Private/Language/locallang_ttc.xlf:images.addFileReference',
                    'collapseAll' => true,
                ],
                'behaviour' => [
                    'allowLanguageSynchronization' => true,
                ],
                'foreign_types' => [
                    '0' => [
                        'showitem' => '
                                --palette--;LLL:EXT:lang/locallang_tca.xlf:sys_file_reference.imageoverlayPalette;imageoverlayPalette,
                                --palette--;;filePalette',
                    ],
                    \TYPO3\CMS\Core\Resource\File::FILETYPE_TEXT => [
                        'showitem' => '
                             --palette--;LLL:EXT:lang/locallang_tca.xlf:sys_file_reference.imageoverlayPalette;imageoverlayPalette,
                             --palette--;;filePalette',
                    ],
                    \TYPO3\CMS\Core\Resource\File::FILETYPE_IMAGE => [
                        'showitem' => '
                            --palette--;LLL:EXT:lang/locallang_tca.xlf:sys_file_reference.imageoverlayPalette;imageoverlayPalette,
                            --palette--;;filePalette',
                    ],
                ],
                'maxitems' => 10,
            ],
            $GLOBALS['TYPO3_CONF_VARS']['GFX']['imagefile_ext']
        ),
    ],
]


Related issues

Duplicates TYPO3 Core - Bug #81314: doubled references upon related record change Under Review 2017-05-23

History

#1 Updated by Florian Wessels 12 months ago

The problem is that

$this->isNestedElementCallRegistered($table, $uid, 'localize')

returns true in localize method of TYPO3\CMS\Core\DataHandling\DataHandler.
This will skip the localization process and the RuntimeException 1486233164 ("Child record was not processed") will be thrown.

#2 Updated by Stephan Schuler 6 months ago

Hey there.

If I'm not completely wrong, that's the same as #81314.

Regards,
Stephan.

#3 Updated by Michael Stucki 12 days ago

  • Status changed from New to Resolved

This bug is a duplicate of #81314. Closing here...

#4 Updated by Michael Stucki 12 days ago

  • Duplicates Bug #81314: doubled references upon related record change added

#5 Updated by Benni Mack 6 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF