Bug #85345

Cannot set "ready to publish" state anymore

Added by Oliver Hader over 1 year ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Database API (Doctrine DBAL)
Target version:
-
Start date:
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:
On Location Sprint

Description

When moving a workspace record into "ready to publish" state, an internal server error is thrown:

An exception occurred while executing 'UPDATE `tt_content` SET `t3ver_stage` = ? WHERE `uid` = ?' with params ["-10", 475]:

Out of range value for column 't3ver_stage' at row 1

The "ready to publish" state has the internal identifier -10 which is not supported anymore since system fields are auto-generated.


Related issues

Follows TYPO3 Core - Feature #85160: Auto create management DB fields from TCA ctrl Closed 2018-06-05

Associated revisions

Revision 8378c8a6 (diff)
Added by Oliver Hader over 1 year ago

[BUGFIX] Allow setting "ready to publish" workspace state again

The "ready to publish" workspace state has the internal negative
identifier -10 which is not supported anymore since system fields
are auto-generated and t3ver_stage defined to be of type unsigned
(positive) integer.

Resolves: #85345
Releases: master
Change-Id: I2cb1f3f5bc65ec30fb510c5f2d2f9fbb9e0d55e9
Reviewed-on: https://review.typo3.org/57301
Tested-by: TYPO3com <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Aljoscha Weber <>
Tested-by: Aljoscha Weber <>
Reviewed-by: Jonas Götze <>
Tested-by: Jonas Götze <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>

History

#1 Updated by Oliver Hader over 1 year ago

  • Due date set to 2018-06-06
  • Start date changed from 2018-06-22 to 2018-06-06
  • Follows Feature #85160: Auto create management DB fields from TCA ctrl added

#2 Updated by Oliver Hader over 1 year ago

  • Due date deleted (2018-06-06)
  • Start date deleted (2018-06-06)
  • Is Regression set to Yes

#3 Updated by Oliver Hader over 1 year ago

  • Sprint Focus set to On Location Sprint

#4 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57301

#5 Updated by Gerrit Code Review over 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57301

#6 Updated by Gerrit Code Review over 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57301

#7 Updated by Andreas Fernandez over 1 year ago

  • Status changed from Under Review to Resolved

#8 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF