Bug #85551

expAll.override.if.isInList is not working

Added by David Bruchmann over 1 year ago. Updated 10 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
TypoScript
Target version:
-
Start date:
2018-07-13
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Having a Menu and want to override some configuration depending on situation the TypoScript

expAll.override.if.isInList

just never has any impact.

In my situation it's not a big problem as the configuration of the HMENU with `alwaysActivePIDlist` is doing the same even with less code.

The problem is nevertheless that the stdWrap-properties are not fully available for some reason and the documentation is missing this point and even has an example with that not-working code here: https://docs.typo3.org/typo3cms/TyposcriptReference/Functions/If/Index.html#isinlist

If that example is not intended being used with `expAll.override` then at least a hint would be desired if the issue can't be fixed in TypoScript.

Other conditions in `expAll.override.if` never have been tested but `equals` never works too.

History

#1 Updated by Susanne Moog about 1 year ago

  • Target version changed from 9.4 to Candidate for patchlevel

#2 Updated by Susanne Moog about 1 year ago

  • Status changed from New to Needs Feedback

It's working fine for me:

Does use expAll:

page > 
page = PAGE
page.23 = HMENU
page.23 {
  entryLevel = 0
  1 = TMENU
  1 {
    expAll = 0
    expAll.override.if.isInList = 3
    expAll.override.if.value = 1,3,5
    expAll.override = 1
    NO = 1
    NO.wrapItemAndSub = |<br />
  }
  2 = TMENU
  2 {
    NO = 1
  }
}

Does not use expAll:

page > 
page = PAGE
page.23 = HMENU
page.23 {
  entryLevel = 0
  1 = TMENU
  1 {
    expAll = 0
    expAll.override.if.isInList = 2
    expAll.override.if.value = 1,3,5
    expAll.override = 1
    NO = 1
    NO.wrapItemAndSub = |<br />
  }
  2 = TMENU
  2 {
    NO = 1
  }
}

I also tested equals, which works equally fine.

Can you provide a more complete example of what isn't working?

#3 Updated by Riccardo De Contardi 10 months ago

  • Status changed from Needs Feedback to Closed
  • Target version deleted (Candidate for patchlevel)

No feedback since the last 90 days => closing this issue.

If you think that this is the wrong decision or experience the issue again and have more information about how to reproduce your problem, please reopen it or open a new issue with a reference to this one.

Thank you and best regards

Also available in: Atom PDF