Bug #85576

Linkvalidator not checking linked content elements with TypoLink

Added by Patrick Broens about 1 year ago. Updated 3 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Linkvalidator
Target version:
-
Start date:
2018-07-16
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If an anchor is added to a TypoLink, using the new TypoLink markup t3://page?uid=x#y, the content element is never checked on its existence.
The InternalLinktype is only checking the page, but not the content element, since it is only checking on recordRef = pages, while the SoftReferenceIndex is breaking this into pages and tt_content, calling the InternalLinkType twice.

How to reproduce:
Have a link in for instance the tt_content field "header_link" like t3://page?uid=x#y pointing to a valid page but not to a valid anchor
Run the checks in the module "Web > Info > Linkvalidator".
No error for the non-existing content element will show up.


Related issues

Related to TYPO3 Core - Bug #84016: impexp: page links are parsed / replaced incorrectely due to error in SoftReferenceIndex Under Review 2018-02-22
Related to TYPO3 Core - Epic #85006: Epic: Improve broken link handling in TYPO3 / linkvalidator rewrite New 2018-02-11

Associated revisions

Revision 916d1c60 (diff)
Added by Patrick Broens 10 months ago

[BUGFIX] Linkvalidator validates linked content elements

This patch makes the LinkValidator check typolinks to tt_content
elements like t3://page?uid=x#y by calling InternalLinktype twice, once
for the page as first part of the SoftReferenceIndex and again for the
tt_content element as second part.

Resolves: #85576
Related: #84016
Releases: master, 8.7
Change-Id: I94243e66f5eff38c9a0b0859a85aac48885e38ba
Reviewed-on: https://review.typo3.org/57612
Reviewed-by: Stephan Großberndt <>
Tested-by: TYPO3com <>
Tested-by: Sybille Peters <>
Reviewed-by: Jörg Bösche <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

Revision 574914eb (diff)
Added by Patrick Broens 10 months ago

[BUGFIX] Linkvalidator validates linked content elements

This patch makes the LinkValidator check typolinks to tt_content
elements like t3://page?uid=x#y by calling InternalLinktype twice, once
for the page as first part of the SoftReferenceIndex and again for the
tt_content element as second part.

Resolves: #85576
Related: #84016
Releases: master, 8.7
Change-Id: I94243e66f5eff38c9a0b0859a85aac48885e38ba
Reviewed-on: https://review.typo3.org/58735
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Patrick Broens about 1 year ago

  • Related to Bug #84016: impexp: page links are parsed / replaced incorrectely due to error in SoftReferenceIndex added

#2 Updated by Gerrit Code Review about 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57612

#3 Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57612

#4 Updated by Patrick Broens about 1 year ago

  • Related to Epic #85006: Epic: Improve broken link handling in TYPO3 / linkvalidator rewrite added

#5 Updated by Gerrit Code Review about 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57612

#6 Updated by Gerrit Code Review about 1 year ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57612

#7 Updated by Gerrit Code Review about 1 year ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57612

#8 Updated by Gerrit Code Review 10 months ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58735

#9 Updated by Patrick Broens 10 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#10 Updated by Gerrit Code Review 10 months ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58735

#11 Updated by Patrick Broens 10 months ago

  • Status changed from Under Review to Resolved

#12 Updated by Benni Mack 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF