Bug #85779

RTE: bold and italic buttons creates span

Added by Wiebke Lauke about 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2018-08-08
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:
On Location Sprint

Description

Hi folks!

I've got a problem with the RTEhtmlarea editor within TYPO3 7.6.31. Pushing the button for bold text it creates <span style="bold;"></span> instead of <strong></strong>. Pushing the button for italic text it creates <span style="italic;"></span> instead of <em></em>.
Thought that was not a problem in further 7.6 version of TYPO3.

Thanks for your help!

#1

Updated by Stephan Großberndt about 3 years ago

  • Project changed from forge.typo3.org to TYPO3 Core
  • Description updated (diff)
  • Category set to RTE (rtehtmlarea + ckeditor)
  • TYPO3 Version set to 7
#2

Updated by Riccardo De Contardi about 3 years ago

  • Status changed from New to Needs Feedback

Can you check if your page TSConfig contains

RTE.default.useCSS = 1

?

See https://docs.typo3.org/typo3cms/extensions/rtehtmlarea/Configuration/PageTsconfig/interfaceConfiguration/Index.html#usecss and https://stackoverflow.com/questions/38779241/typo3-rte-bold-button-wrap

Without that code, I am not able to reproduce the issue.

Thank you.

#3

Updated by Susanne Moog almost 3 years ago

  • Sprint Focus set to On Location Sprint
#4

Updated by Benni Mack almost 3 years ago

  • Status changed from Needs Feedback to Closed

Hey Wiebke,

yes. please remove the option as mentioned. This is ugly. For v8 and v9 this is already fixed. If you feel that we've made a wrong decision here, please let us know via slack or feel free to open another ticket!

Thanks for your report - it helps to identify better how we should fix things and document changes!
Benni.

Also available in: Atom PDF