Bug #85917

Exception in Template Module when having sys_template records in workspaces

Added by Sebastian Michaelsen 9 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2018-08-21
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Updating our TYPO3 installation to 8.7.19 broke the Template module.

Argument 2 passed to TYPO3\CMS\Core\Imaging\IconFactory::getIconForRecord() must be of the type array, null given, called in /[snip]/vendor/typo3/cms/typo3/sysext/tstemplate/Classes/Controller/TypoScriptTemplateModuleController.php on line 602 

This error occurs when you have sys_template records with pid = -1 (i.e. you're using workspaces).


Related issues

Related to TYPO3 Core - Bug #81430: Root > TS Template module: show more information (like disabled template) Closed 2017-06-02

Associated revisions

Revision c72713ab (diff)
Added by Oliver Hader 9 months ago

[BUGFIX] Resolve workspace records for template module overview

BackendWorkspaceRestriction automatically resolves specific records
already for a given workspace. In most cases this seems to be fine to
omit the usual workspace overlay processing. However, especially when
dealing with references and page tree assignments, it just contains
wrong information.

For instance all workspace versions have the `pid` column set to -1
which of course cannot be resolved as valid page then.

Resolves: #85917
Releases: master, 8.7
Change-Id: Ibe20037b25770bea8f58d1a8bba785ca43ac26cb
Reviewed-on: https://review.typo3.org/57982
Tested-by: Susanne Moog <>
Reviewed-by: Susanne Moog <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>
Tested-by: TYPO3com <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>

Revision 90352bb0 (diff)
Added by Oliver Hader 9 months ago

[BUGFIX] Resolve workspace records for template module overview

BackendWorkspaceRestriction automatically resolves specific records
already for a given workspace. In most cases this seems to be fine to
omit the usual workspace overlay processing. However, especially when
dealing with references and page tree assignments, it just contains
wrong information.

For instance all workspace versions have the `pid` column set to -1
which of course cannot be resolved as valid page then.

Resolves: #85917
Releases: master, 8.7
Change-Id: Ibe20037b25770bea8f58d1a8bba785ca43ac26cb
Reviewed-on: https://review.typo3.org/58164
Reviewed-by: Oliver Hader <>
Tested-by: TYPO3com <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Gerrit Code Review 9 months ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57982

#2 Updated by Oliver Hader 9 months ago

  • Related to Bug #81430: Root > TS Template module: show more information (like disabled template) added

#3 Updated by Oliver Hader 9 months ago

  • Is Regression set to Yes

#4 Updated by Gerrit Code Review 9 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57982

#5 Updated by Gerrit Code Review 9 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57982

#6 Updated by Gerrit Code Review 9 months ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58164

#7 Updated by Oliver Hader 9 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Benni Mack 8 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF