Bug #86134

Protocol is added twice to URL in BackendUtility::getViewDomain

Added by Georg Ringer over 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2018-09-04
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The method \TYPO3\CMS\Backend\Utility\BackendUtility::getViewDomain adds the protocol twice because of $domain = $protocol . '://' . $domain;

This leads to the URL http://http://demo.vm


Related issues

Duplicated by TYPO3 Core - Bug #86140: Legacy backend preview url generation generates URL with duplicated protocol Closed 2018-09-04

Associated revisions

Revision 2ede3295 (diff)
Added by Benni Mack over 1 year ago

[BUGFIX] Do not double-prepend the URL scheme on preview URLs

When having a pseudo-site the view functionality is broken
due to some different handling how to deal with protocols.

Resolves: #86134
Releases: master
Change-Id: Ia3b08ce968ecfdce631ce9c7ff9c973cfb25eef5
Reviewed-on: https://review.typo3.org/58177
Tested-by: TYPO3com <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>

History

#1 Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58177

#2 Updated by Benni Mack over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Andreas Fernandez over 1 year ago

  • Duplicated by Bug #86140: Legacy backend preview url generation generates URL with duplicated protocol added

#4 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF