Bug #86211

Fatal error in DebugExceptionHandler

Added by Nicole Cordes almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
-
Target version:
-
Start date:
2018-09-09
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Given:

- try to install extension "devtools" in its current TER version (check "I know what I'm doing..." dialog)

Expected:

- the extension is not compatible yet, an exception should be visible

Actual:

- an fatal error is thrown, because an array parameter is expected, null is given

Background:

- \TYPO3\CMS\Core\Utility\ExtensionManagementUtility::loadSingleExtLocalconfFiles uses require without method context - thus no argument is available in trace


Related issues

Related to TYPO3 Core - Feature #86070: Refine DebugExceptionHandlerClosedMarkus Poerschke2018-09-01

Actions
#1

Updated by Gerrit Code Review almost 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58242

#2

Updated by Markus Klein almost 3 years ago

#3

Updated by Nicole Cordes almost 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#4

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF