Project

General

Profile

Actions

Bug #86258

closed

Scheduler - Next execution calculation throws exception after save

Added by Joerg Boesche almost 6 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
scheduler
Target version:
Start date:
2018-09-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
scheduler,task,backend,exception
Complexity:
medium
Is Regression:
Sprint Focus:

Description

When creating a new task in den scheduler module and save them an exception with "date() expects parameter 2 to be integer, string given" throws.

TYPO3 v9.4.0
How to reproduce:
  • Open scheduler module in the backend
  • Create new task
  • Select any type of task (extbase, console command, ...)
  • Add a frequency (e.g. 3600 or * */1 * * *)
  • Click on "Save" and "Close" Button
  • After saving and rendering the scheduler task overview the error occurs

Affected line in SchedulerModuleController

$nextDate = date($dateFormat, $schedulerRecord['nextexecution']);

TypeError
date() expects parameter 2 to be integer, string given

in SchedulerModuleController.php line 953

                    // Also hide the date if task is disabled (the information doesn't make sense, as it will not run anyway)
                    if ($isRunning || $schedulerRecord['disable']) {
                        $nextDate = '-';
                    } else {
                        $nextDate = date($dateFormat, $schedulerRecord['nextexecution']);
                        if (empty($schedulerRecord['nextexecution'])) {
                            $nextDate = $this->getLanguageService()->getLL('none');
                        } elseif ($schedulerRecord['nextexecution'] < $GLOBALS['EXEC_TIME']) {
                            $labels[] = [


Files


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #86263: Fix fatal in SchedulerModuleController on some DB driversClosed2018-09-15

Actions
Actions #1

Updated by Joerg Boesche almost 6 years ago

  • Subject changed from Scheduler - Next execution calculation throws exception on save to Scheduler - Next execution calculation throws exception after save
Actions #2

Updated by Georg Ringer almost 6 years ago

  • Status changed from New to Needs Feedback

I can't reproduce that. The field nextececution is defined as int in the DB and in all my tasks it is defined as string.

can you reproduce that on a different system? which DB are you using or is the field in your case maybe not an integer in the DB?

Actions #3

Updated by Georg Ringer almost 6 years ago

  • Status changed from Needs Feedback to Resolved

closed with #86263

Actions #4

Updated by Georg Ringer almost 6 years ago

  • Related to Bug #86263: Fix fatal in SchedulerModuleController on some DB drivers added
Actions #5

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF