Bug #86336

search_result_labels setting ignored when executing System Action

Added by Sascha Löffler about 1 year ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2018-09-20
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When creating a SQL Query Action for example to export a CSV, the setting `Use formatted strings, labels and dates instead of original values for results` is correctly used in the Query Editor, but when executing the Action, it is ignored and always enabled.

In /typo3/sysext/sys_action/Classes/ActionTask.php
on line 814

$GLOBALS['SOBE']->MOD_SETTINGS['search_result_labels'] = 1;

should be

$GLOBALS['SOBE']->MOD_SETTINGS['search_result_labels'] = $sql_query['qC']['search_result_labels'];

Related issues

Related to TYPO3 Core - Bug #86396: search_result_labels setting ignored when executing System Action Closed 2018-09-27

History

#1 Updated by Sascha Löffler about 1 year ago

Same case probably for TYPO3 v9 as well since the code is the same.
But haven't verified it.

#2 Updated by Sascha Löffler about 1 year ago

  • Status changed from New to In Progress
  • Assignee set to Sascha Löffler

#3 Updated by Gerrit Code Review 12 months ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58364

#4 Updated by Sascha Löffler 12 months ago

  • Related to Bug #86396: search_result_labels setting ignored when executing System Action added

#5 Updated by Tymoteusz Motylewski 12 months ago

  • Status changed from Under Review to Closed

Also available in: Atom PDF