Bug #86396

search_result_labels setting ignored when executing System Action

Added by Sascha Löffler 12 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2018-09-27
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When creating a SQL Query Action for example to export a CSV, the setting `Use formatted strings, labels and dates instead of original values for results` is correctly used in the Query Editor, but when executing the Action, it is ignored and always enabled.

In /typo3/sysext/sys_action/Classes/ActionTask.php
on line 826

$GLOBALS['SOBE']->MOD_SETTINGS['search_result_labels'] = 1;

should be

$GLOBALS['SOBE']->MOD_SETTINGS['search_result_labels'] = $sql_query['qC']['search_result_labels'];

Also for TYPO3 v9 the settings should be correctly set for the QueryView.

See also #86336 for the same issue in TYPO3 v8


Related issues

Related to TYPO3 Core - Bug #86336: search_result_labels setting ignored when executing System Action Closed 2018-09-20

Associated revisions

Revision 3ced58e9 (diff)
Added by Sascha Löffler 12 months ago

[BUGFIX] Sql query export to use search_result_labels setting

Releases: master, 8.7
Resolves: #86396
Change-Id: I198fe52a8024dcf392582a78c3fce0f134ed6b7a
Reviewed-on: https://review.typo3.org/58406
Tested-by: TYPO3com <>
Reviewed-by: Frank Naegler <>
Tested-by: Frank Naegler <>
Reviewed-by: Tymoteusz Motylewski <>
Tested-by: Tymoteusz Motylewski <>

Revision 4bd4c8b8 (diff)
Added by Sascha Löffler 9 months ago

[BUGFIX] Sql query export to use search_result_labels setting

Releases: master, 8.7
Resolves: #86396
Change-Id: I198fe52a8024dcf392582a78c3fce0f134ed6b7a
Reviewed-on: https://review.typo3.org/58839
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Sascha Löffler 12 months ago

  • Related to Bug #86336: search_result_labels setting ignored when executing System Action added

#2 Updated by Gerrit Code Review 12 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58406

#3 Updated by Gerrit Code Review 12 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58406

#4 Updated by Tymoteusz Motylewski 12 months ago

please create just one ticket even if multiple TYPO3 versions are affected.

#5 Updated by Sascha Löffler 12 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

#7 Updated by Gerrit Code Review 11 months ago

  • Status changed from Closed to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58839

#8 Updated by Sascha Löffler 9 months ago

  • Status changed from Under Review to Resolved

#9 Updated by Benni Mack 5 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF