Bug #86355

Target field in redirects record can contain typolink syntax but this is not processed before redirecting

Added by Jigal van Hemert over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Category:
Frontend
Target version:
-
Start date:
2018-09-22
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The target field in a redirects record can contain more than a simple URL (either external or t3:// syntax). In fact it may contain a complete typolink syntax with space separated urn, class, target and title. If there is a t3:// syntax this will be processed and the other parts are ignored. In case of an external URL there is no further processing and a redirect to something like

http://example.org - - "Example Title"

may be executed. At least in Firefox this can lead to an error

Corrupted Content Error

The site at http://demo9.ddev.local/nu/ has experienced a network protocol violation that cannot be repaired.

The page you are trying to view cannot be shown because an error in the data transmission was detected.

    Please contact the website owners to inform them of this problem.

Response headers:
HTTP/1.1 301 Moved Permanently
Server: nginx/1.13.6
Date: Sat, 22 Sep 2018 20:39:59 GMT
Content-Type: text/html; charset=UTF-8
Transfer-Encoding: chunked
Connection: keep-alive
Expires: 0
Last-Modified: Sat, 22 Sep 2018 20:39:58 GMT
Cache-Control: no-cache, must-revalidate
Pragma: no-cache
X-Redirect-By: TYPO3
location: http://nu.nl - - "Example Title"

#1

Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58374

#2

Updated by Jigal van Hemert over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#3

Updated by Benni Mack over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF