Bug #86421

Preview of translated pages not working anymore

Added by Richard Haeser 11 months ago. Updated 11 months ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Link Handling, Site Handling & Routing
Target version:
Start date:
2018-09-28
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When you want to open the page you are editing by using the eye-icon in the backend, it won't generate the correct link to the frontend anymore resulting in a page with the original language.

Seems to be after https://review.typo3.org/#/c/58149/

See screenshot for more information.

Screenshot 2018-09-28 at 14.05.17.png View (55 KB) Richard Haeser, 2018-09-28 14:07

Associated revisions

Revision 241b7469 (diff)
Added by Oliver Hader 11 months ago

[BUGFIX] Transform language parameter when previewing translated pages

When previewing translated pages in the backend, URLs contain `&L=x` at
the end. This is due to a missing transformation into the `_language`
parameter as well a missing SiteLanguage resolving.

Resolves: #86421
Releases: master
Change-Id: I5da496d0224635b1ee849dd7a724145ad2c0d408
Reviewed-on: https://review.typo3.org/58438
Reviewed-by: Richard Haeser <>
Tested-by: Richard Haeser <>
Tested-by: TYPO3com <>
Reviewed-by: Josef Glatz <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Richard Haeser 11 months ago

  • Target version set to 9 LTS

#2 Updated by Richard Haeser 11 months ago

In the view module, the preview URL is generated correctly.

#3 Updated by Richard Haeser 11 months ago

  • Category set to Link Handling, Site Handling & Routing

#4 Updated by Oliver Hader 11 months ago

  • Assignee set to Oliver Hader

#5 Updated by Oliver Hader 11 months ago

  • Status changed from New to In Progress

#6 Updated by Gerrit Code Review 11 months ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58438

#7 Updated by Gerrit Code Review 11 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58438

#8 Updated by Oliver Hader 11 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Benni Mack 11 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF