Bug #86621

Error editing start page with single-tree translations for non-admin user

Added by Chris Müller 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-10-10
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In TYPO3 9.5.0 I have a single-tree website with two languages (en/de).

Now I configured the access rights for my editors. The start page with uid 3 is set as starting point for the DB mount.

The group has all permissions set for the start page:

Permissions

Now the editor (who is in the respective group) edits the page properties of the English start page and want to save the changes, the following error message appears:

1: Attempt to modify record 'Home page' (pages:79) without permission. Or non-existing page.

The same error message occurs with the German version.

In the database is for page uid 79 the field "l10n_parent" set to 3:

Extract from pages table

The saving for other pages in deeper levels of the web site works correctly.

permissions.png View - Permissions (14 KB) Chris Müller, 2018-10-10 14:32

db_pages.png View - Extract from pages table (10.1 KB) Chris Müller, 2018-10-10 14:38


Related issues

Related to TYPO3 Core - Bug #86575: Missing page access for root-page translations New 2018-10-05

History

#1 Updated by Chris Müller 2 months ago

  • Description updated (diff)

#2 Updated by Riccardo De Contardi about 2 months ago

  • Related to Bug #86575: Missing page access for root-page translations added

#3 Updated by Riccardo De Contardi about 2 months ago

  • Status changed from New to Closed

I close this issue as a duplicate of #86575 , please continue the discussion there, thank you.
I have added there a reference to this issue to keep track of it

If you think that this is the wrong decision, then please reopen it or open a new ticket and add a relation to this ticket number.

Thank you and best regards

Also available in: Atom PDF