Bug #86625

"No pseudo-site found in root line of page" when executing upgrade wizard

Added by Tymoteusz Motylewski 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2018-10-11
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:
On Location Sprint

Description

When executing upgrade wizard in the install tool, I'm getting
"No pseudo-site found in root line of page 161737" error.

Where page "161737" is a translation of some page (sys_language_uid =1)

Is that correct that the wizzard is trying to find site per translated page id ?
I've dig into the code and what is happening is that
PopulatePageSlugs.php->populateSlugs calls
$slugHelper->isUniqueInSite method

then in line ~269 of the SlugHelper there is a foreach loop with

 matchByPageId((int)$record['uid']); 

and this is a translated uid
Then matchByPageId calls pseudoSiteFinder->getSiteByPageId($pageId, $rootLine); (edited)
and get SiteByPageID throws an exception, as there is no site configuration for translated page.

Seems we're missing some check for translated page?

What is also worth noticing is that \TYPO3\CMS\Core\DataHandling\SlugHelper::resolveParentPageRecord is NOT called.


Related issues

Related to TYPO3 Core - Bug #86195: Localization of page fails because of SiteNotFoundException Resolved 2018-09-07

Associated revisions

Revision 12bf0ed0 (diff)
Added by Benni Mack about 2 months ago

[BUGFIX] Always use default language for uniqueInSite

SlugHelper fetches records of the same language, and takes the
pageId of the current language record (uid), which is wrong.
For records, it must be 'pid', for pages it must be 'uid', but for
translated pages it must be 'pages.l10n_parent'.

Resolves: #86625
Releases: master
Change-Id: I7af6f0438f5a90169505069c557792d4e7b08b7c
Reviewed-on: https://review.typo3.org/58722
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>
Tested-by: TYPO3com <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Tymoteusz Motylewski 2 months ago

  • Related to Bug #86195: Localization of page fails because of SiteNotFoundException added

#2 Updated by Tymoteusz Motylewski 2 months ago

  • Related to Bug #86622: No pseudo-site found in root line of page xxx with Pagetype Folder added

#3 Updated by Tymoteusz Motylewski 2 months ago

  • Related to deleted (Bug #86622: No pseudo-site found in root line of page xxx with Pagetype Folder)

#4 Updated by Susanne Moog about 2 months ago

  • Sprint Focus set to On Location Sprint

#5 Updated by Gerrit Code Review about 2 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58722

#6 Updated by Gerrit Code Review about 2 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58722

#7 Updated by Gerrit Code Review about 2 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58722

#8 Updated by Gerrit Code Review about 2 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58722

#9 Updated by Benni Mack about 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF