Project

General

Profile

Actions

Bug #86628

closed

Linked files not referenced in backend filelist

Added by Jörg Wiedemann almost 6 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2018-10-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I have a problem with referenced files and images in the backend filelist. If i e.g. place an image on a page, this image is referenced in T3 BE filelist, so i can‘t delete this file in the filelist. Thats ok. But, if this image is linked to a local file maybe a .pdf or something, this pdf-file is not referenced in the filelist. So i can delete this file and there is no warning. It’s a 8.7. Installation. In T3 6.2 everything was ok. I posted this issue on StackOverflow, Rudy Gnodde tested this in T3 7.6, it seems to be ok there.

DB: sys_file_reference => FIELD:link = t3://file?uid=3


Files

screen1.jpg (43.6 KB) screen1.jpg Screen BE filelist Jörg Wiedemann, 2018-10-11 14:41
screen2.jpg (46.7 KB) screen2.jpg Screen content element Jörg Wiedemann, 2018-10-11 14:41

Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #81831: sys_refindex and bodytext columns: link reference to files not workingClosed2017-07-11

Actions
Related to TYPO3 Core - Bug #84016: impexp: page links are parsed / replaced incorrectely due to error in SoftReferenceIndexClosed2018-02-22

Actions
Actions #1

Updated by Rudy Gnodde almost 6 years ago

It looks like links to files in this way aren't added to the sys_refindex table. I tried it by adding a link to a file in a file reference and in the header link field for tt_content.

Actions #2

Updated by Franz Kugelmann over 4 years ago

To add some more information here:
The problem starts with v8 and is still existent in v10.1.
If you add a media file in a textmedia content element and then place a link to lets say a pdf within that sys_file_reference, then this usage of the file is neither recognized in the fileList (how often is that file used) nor in the check if the file can actually be deleted.
The reason is in the different way this information is placed in sys_refindex since v8. Now such a link looks like this:

ref_table ref_uid ref_string
_STRING 0 t3://file?uid=3

And that is not reflected in \TYPO3\CMS\Filelist\FileList::makeRef or in the delete check.

A very similar problem (links from within RTE) was solved in #81831. Probably the same solution applies.

Actions #3

Updated by Franz Kugelmann over 4 years ago

  • Related to Bug #81831: sys_refindex and bodytext columns: link reference to files not working added
Actions #4

Updated by Benni Mack over 4 years ago

  • Related to Bug #84016: impexp: page links are parsed / replaced incorrectely due to error in SoftReferenceIndex added
Actions #5

Updated by Benni Mack over 4 years ago

  • Status changed from New to Resolved

Fixed with issue #84016 - will be released in the next v9 / v10 versions.

Actions #6

Updated by Benni Mack over 4 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF