Bug #86657

DataHandler: Missing timestamp parameter when getting RecordHistoryStore

Added by Thorben Nissen 11 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
DataHandler aka TCEmain
Target version:
Start date:
2018-10-15
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
delete record, sys history
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

In DataHandler::getRecordHistoryStore 4 parameters are provided when creating an instance of `RecordHistoryStore`: $userType, $userId, $originalUserId, $workspaceId.
RecordHistoryStore though takes 5: $userType, $userId, $originalUserId, $tstamp, $workspaceId. This would lead to wrong timestamps or, in my case of a newly create BE_USER object an SQL error because the timestamp is set to -99 (workspace id).

Associated revisions

Revision a42e0f48 (diff)
Added by Georg Ringer 11 months ago

[BUGFIX] Fix argument ordering of RecordHistoryStore

The DataHandler must use the correct ordering of arguments of
RecordHistoryStore. Furthermore the sorting of the arguments in the
doc block is fixed.

Resolves: #86657
Releases: master
Change-Id: I3054cb5a94f0e84a5c93accfd6349b7c24dbc885
Reviewed-on: https://review.typo3.org/58641
Tested-by: TYPO3com <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Stefan Neufeind <>
Tested-by: Stefan Neufeind <>

History

#1 Updated by Gerrit Code Review 11 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58641

#2 Updated by Gerrit Code Review 11 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58641

#3 Updated by Georg Ringer 11 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Benni Mack 5 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF