Bug #86676

Extension configuration not updated both in TYPO3 9

Added by Aimeos no-lastname-given 11 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Extension Manager
Start date:
2018-10-17
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

TYPO3 9 contains two sections in LocalConfiguration.php with extension settings:

    'EXT' => [
        'extConf' => [
            'aimeos' => 'a:8:{s:8:"siteCode";s:7:"default";s:7:"cleanDb";s:1:"1";s:11:"useDemoData";s:0:"";s:20:"useRealUrlAutoConfig";s:1:"1";s:9:"cacheName";s:5:"Typo3";s:6:"useAPC";s:1:"0";s:9:"apcPrefix";s:3:"t3:";s:12:"showPageTree";s:1:"0";}',
        ]
    ]

and
    'EXTENSIONS' => [
        'aimeos' => [
            'apcPrefix' => 't3:',
            'cacheName' => 'Typo3',
            'cleanDb' => '1',
            'showPageTree' => '0',
            'siteCode' => 'default',
            'useAPC' => '0',
            'useDemoData' => '',
            'useRealUrlAutoConfig' => '1',
        ],
    ]

Using the new ExtensionConfiguration class updates the EXT/extConf section but not the new EXTENSIONS section:

$object = $objectManager->get( 'TYPO3\CMS\Core\Configuration\ExtensionConfiguration' );
$object->set( 'aimeos', 'useDemoData', '' );

Thus, the new "Settings -> Extension Configuration" panel shows the settings from EXTENSIONS which haven't been updated, so users see wrong values.

History

#1 Updated by Georg Ringer 11 months ago

  • Status changed from New to Needs Feedback

I can't reproduce that on current master, using the news extension and setting

 $object = $this->objectManager->get( 'TYPO3\CMS\Core\Configuration\ExtensionConfiguration' );
 $object->set( 'news', 'tagPid', '91919' );

in the controller. 91919 is set for both new and old variant, also empty string works. Can you retry maybe in a clean installation?

#2 Updated by Aimeos no-lastname-given 11 months ago

Tested with new 9.5.1 and is fixed in that version. Thanks!

#3 Updated by Georg Ringer 11 months ago

  • Status changed from Needs Feedback to Resolved

#4 Updated by Benni Mack 5 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF