Bug #86678

Exception when using workspaces and using a site configuration

Added by Riccardo De Contardi about 1 year ago. Updated 7 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2018-10-17
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
workspaces, site configuration
Complexity:
Is Regression:
Sprint Focus:

Description

Prerequisites

- fresh TYPO3 9.5.0 installation
- a very simple tree like this one

[ID=1] Home page (is the root)
   |
   +-- [ID=3] A page

- a site configuration, here is mine:

rootPageId: 1
base: 'https://typo3.9.test.it:8890/'
baseVariants: {  }
languages:
  -
    title: Italian
    enabled: true
    languageId: '0'
    base: /
    typo3Language: it
    locale: it_IT.UTF-8
    iso-639-1: it
    navigationTitle: Italiano
    hreflang: it-IT
    direction: ''
    flag: it
  -
    title: English
    enabled: true
    languageId: '1'
    base: /en/
    typo3Language: default
    locale: en_EN.UTF-8
    iso-639-1: en
    navigationTitle: English
    hreflang: en-EN
    direction: ''
    fallbackType: strict
    flag: gb
errorHandling: {  }
routes: {  }

- Workspaces ext enabled

steps to reproduce

1. create a workspace, name: "Custom Workspace"; assign the home page [ID=1] as mount point (db_mountpoints)
2. create the page "test page" (let's assume it has id=5) as a child of home page:

[ID=1] Home page (is the root)
   |
   +-- [ID=3] A page
   |
   +--[ID=5] test page

3. go to custom workspace
4. edit the page "test page", change something, e.g. the subtitle, save

results:

you get an exception:

Whoops, looks like something went wrong.

(1/1) #1534710048 TYPO3\CMS\Core\Exception\SiteNotFoundException
No pseudo-site found in root line of page 6

in /TYPO3-dists/typo3_src-9.5.0/typo3/sysext/core/Classes/Site/PseudoSiteFinder.php line 178

the page with ID=6 has been created in the workspace - the "simplified" pages tables looks like:

uid pid tstamp t3ver_oid t3ver_id t3ver_label t3ver_wsid
5 1 1539803988 0 0 0
6 -1 1539804015 5 1 Auto-created for WS #1 1

I can reproduce this issue with both a fresh 9.5.0 and 9.5.1-dev (latest master)

Let me know if you need the full error or further information. Thank you.


Related issues

Related to TYPO3 Core - Bug #86186: No pseudo-site found in root line for workspaces Closed 2018-09-07

Associated revisions

Revision b3c17046 (diff)
Added by Benni Mack 10 months ago

[BUGFIX] Fix various "No pseudo-site found in root line of page" errors

Fixes workspace resolving etc.

The !empty statement is wrong as a string value "0" would not expect the
right return. This fixes the detection of l10n_parent.
Also check for sys_language_uid, too, to get the pid of the record
instead of its parent.

This also fixes opening categories (sys_category) when using EXT:news,
which calls this condition in TCA:
'displayCond' => 'USER:' . \TYPO3\CMS\Core\Compatibility\
PseudoSiteTcaDisplayCondition::class . '->isInPseudoSite:pages:false',

Check array index exists in SiteResolving.

Resolves: #79606
Resolves: #86186
Resolves: #86622
Resolves: #86678
Resolves: #86684
Releases: master, 9.5
Change-Id: If3ddf5eead2dddd51db3bcf751d71d3bc362ef35
Reviewed-on: https://review.typo3.org/59229
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>

Revision aa08d433 (diff)
Added by Benni Mack 10 months ago

[BUGFIX] Fix various "No pseudo-site found in root line of page" errors

Fixes workspace resolving etc.

The !empty statement is wrong as a string value "0" would not expect the
right return. This fixes the detection of l10n_parent.
Also check for sys_language_uid, too, to get the pid of the record
instead of its parent.

This also fixes opening categories (sys_category) when using EXT:news,
which calls this condition in TCA:
'displayCond' => 'USER:' . \TYPO3\CMS\Core\Compatibility\
PseudoSiteTcaDisplayCondition::class . '->isInPseudoSite:pages:false',

Check array index exists in SiteResolving.

Resolves: #79606
Resolves: #86186
Resolves: #86622
Resolves: #86678
Resolves: #86684
Releases: master, 9.5
Change-Id: If3ddf5eead2dddd51db3bcf751d71d3bc362ef35
Reviewed-on: https://review.typo3.org/59453
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Riccardo De Contardi about 1 year ago

  • Description updated (diff)

#2 Updated by Riccardo De Contardi about 1 year ago

  • Related to Bug #86186: No pseudo-site found in root line for workspaces added

#3 Updated by Gerrit Code Review 11 months ago

  • Status changed from New to Under Review

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59229

#4 Updated by Gerrit Code Review 10 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59453

#5 Updated by Benni Mack 10 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Benni Mack 7 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF