Bug #87036

TypoScript getText "site" can't retrieve nested properties

Added by Josef Glatz 9 months ago. Updated 7 months ago.

Status:
Rejected
Priority:
Must have
Assignee:
-
Category:
TypoScript
Start date:
2018-11-23
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Why another issue for that?

As described in #86978, it is not possible to retrieve nested values as explained in https://review.typo3.org/#/c/58434/3/typo3/sysext/core/Documentation/Changelog/master/Feature-86422-IntroduceSiteForTypoScriptDataGetTextProperty.rst. The first patch only takes care of catching the exception.

Problem

The following getText values for example produces an exception (which get's logged since https://review.typo3.org/#/c/58947/) and will silently not work:

{site:configuration.rootPageId}
{site:identifier}

Expectation

According to the mentioned RsT of the feature, this must work also with nested values


Related issues

Related to TYPO3 Core - Task #87434: site:identifier is not available Closed 2019-01-14
Follows TYPO3 Core - Bug #86978: TypoScript getText "site" can't retrieve all properties Closed 2018-11-22

History

#1 Updated by Josef Glatz 9 months ago

  • Due date set to 2018-11-23
  • Start date changed from 2018-11-29 to 2018-11-23
  • Follows Bug #86978: TypoScript getText "site" can't retrieve all properties added

#2 Updated by Josef Glatz 9 months ago

  • Due date deleted (2018-11-23)

#3 Updated by Josef Glatz 7 months ago

  • Related to Task #87434: site:identifier is not available added

#4 Updated by Georg Ringer 7 months ago

  • Status changed from New to Rejected

the rst states that the configuration is returned, nothing else.

  • {site:configuration.rootPageId}: {site:rootPageId}: should work
  • {site:identifier} : identifier is not part of the configuration

the identifier however will be returned once #87434 is resolved. therefore I am closing this issue

Also available in: Atom PDF