Bug #87121

Content fallback does not work, when page translation does not exist yet

Added by Helmut Hummel about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-12-11
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Given content fallback is configured
And a page "foo" exists only in default language English, but not in translation to Danish
I would expect that generated links to Danish translation would fall back to showing English content

Actual result:

English URI: /en/foo
Danish URI: /da/foo

And requesting /da/foo leads to a 404, because there is not translated page that has a slug

Possible solutions:
  1. If content fallback is configured, generate URIs like /da/?id=42 (which currently would work properly)
  2. Implement fallback in URI resolving, so that /da/foo properly resolves to page id 42 even with no slug in translation is available

Side note:

If a page translation records exists but is set to hidden everything works like expected


Related issues

Is duplicate of TYPO3 Core - Bug #86595: No Language FallbackClosedAnja Leichsenring2018-10-08

Actions
Is duplicate of TYPO3 Core - Bug #86762: Site-Configuration defined language fallbacks not workingClosedAnja Leichsenring2018-10-26

Actions
#1

Updated by Wittkiel Gruppe about 2 years ago

Duplicate of #86595 and #86762?

#2

Updated by Helmut Hummel about 2 years ago

  • Is duplicate of Bug #86595: No Language Fallback added
#3

Updated by Helmut Hummel about 2 years ago

  • Is duplicate of Bug #86762: Site-Configuration defined language fallbacks not working added
#4

Updated by Helmut Hummel about 2 years ago

  • Status changed from New to Closed

yes indeed. closed as duplicate

Also available in: Atom PDF